Migration help for gulp-typescript 3

TypeScript 2.0 has been released! Following this release, gulp-typescript 3 is now also available. This page gives an explanation of the (breaking) changes and the changes that are required to use this new version. 1. TypeScript is not bundled anymore Previously, gulp-typescript would automatically use the latest stable release

Read more

Combine TypeScript with Babel

TypeScript has downlevel emit for must constructs it supports. For instance, when you use a let declaration, it will be emitted as a normal variable when targeting ES3 or ES5. However, not all cases are supported. If you're using a block scoped variable (let or const) in a loop with

Read more

Using VSCode with gulp-typescript

Since TypeScript 1.5 is just released, it's a good moment to take a look at how we can integrate the new Visual Studio Code with gulp-typescript. Both support TypeScript 1.5 out of the box, and have support for a universal configuration file called tsconfig.json. About TypeScript 1.

Read more

Announcing Microfill

Previous week I released Microfill, a tool that dynamically loads the polyfills that are needed. For example, a Promise polyfill will only be loaded if Promise isn't supported in the current browser. How does that work? Instead of loading the script file, a file generated by Microfill is loaded. That

Read more